Discussion:
X not starting after update
(too old to reply)
Chris Elvidge
2021-07-12 11:31:04 UTC
Permalink
My Slackware system is a Virtual machine on Virtual Box 6.1.22 r144080
(Qt5.6.2) on Windows 10. I don't have Guest Additions installed (they
haven't been needed in the past.)

Slackware 15 (i.e. mirror is slackware64-current)
I'm using the stock 5.12.16 huge kernel at present.

After upgrading (slackpkg upgrade-all) X will not complete startup
/etc/X11/xinit/startx -> startx.xfce.

Anyone have any hints where to go from here?
Any more information required?


X.Org X Server 1.20.12
X Protocol Version 11, Revision 0
[ 81.153] Build Operating System: Slackware 15.0 Slackware Linux Project
[ 81.158] Current Operating System: Linux slack15.local 5.12.16 #1
SMP Sun Jul 11 12:21:54 CDT 2021 x86_64
[ 81.158] Kernel command line: BOOT_IMAGE=5.12.XX-huge ro root=802
vt.default_utf8=1
[ 81.168] Build Date: 09 July 2021 01:32:31PM
[ 81.173]
[ 81.178] Current version of pixman: 0.40.0

Last lines of Xorg.0.log from failed startup

[ 87.386] (EE)
[ 87.386] (EE) Backtrace:
[ 87.387] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x135) [0x591985]
[ 87.390] (EE) 1: /lib64/libpthread.so.0 (funlockfile+0x50)
[0x7f22ca701400]
[ 87.395] (EE) 2: /lib64/libc.so.6 (gsignal+0x9b) [0x7f22ca54badb]
[ 87.397] (EE) 3: /lib64/libc.so.6 (abort+0x102) [0x7f22ca532526]
[ 87.400] (EE) 4: /lib64/libc.so.6 (__assert_fail_base.cold+0xf)
[0x7f22ca53241f]
[ 87.403] (EE) 5: /lib64/libc.so.6 (__assert_fail+0x42) [0x7f22ca543492]
[ 87.405] (EE) 6: /usr/lib64/xorg/modules/libglamoregl.so
(glamor_get_modifiers+0x2a3) [0x7f22c9c8efe3]
[ 87.408] (EE) 7: /usr/lib64/xorg/modules/libglamoregl.so
(glamor_egl_exchange_buffers+0x479) [0x7f22c9c8fea9]
[ 87.410] (EE) 8: /usr/lib64/xorg/modules/libglamoregl.so
(glamor_gbm_bo_from_pixmap+0x1a) [0x7f22c9c8feca]
[ 87.413] (EE) unw_get_proc_name failed: no unwind info found [-10]
[ 87.413] (EE) 9: /usr/lib64/xorg/modules/drivers/modesetting_drv.so
(?+0x0) [0x7f22c9fc8d5b]
[ 87.414] (EE) 10: /usr/libexec/Xorg
(present_register_complete_notify+0x1a3c) [0x511bbc]
[ 87.414] (EE) 11: /usr/libexec/Xorg (present_extension_init+0x499)
[0x50e299]
[ 87.414] (EE) 12: /usr/libexec/Xorg
(present_register_complete_notify+0x2542) [0x5126c2]
[ 87.415] (EE) 13: /usr/libexec/Xorg
(present_register_complete_notify+0x1224) [0x5113a4]
[ 87.415] (EE) 14: /usr/libexec/Xorg (SendErrorToClient+0x334) [0x43fc34]
[ 87.416] (EE) 15: /usr/libexec/Xorg (InitFonts+0x3a4) [0x443ac4]
[ 87.419] (EE) 16: /lib64/libc.so.6 (__libc_start_main+0xcd)
[0x7f22ca5341ad]
[ 87.420] (EE) 17: /usr/libexec/Xorg (_start+0x2a) [0x42e19a]
[ 87.420] (EE)
[ 87.420] (EE)
Fatal server error:
[ 87.420] (EE) Caught signal 6 (Aborted). Server aborting
[ 87.420] (EE)
[ 87.420] (EE)
Please consult the The X.Org Foundation support
at http://wiki.x.org
for help.
[ 87.420] (EE) Please also check the log file at
"/var/log/Xorg.0.log" for additional information.
[ 87.420] (EE)
[ 87.460] (EE) Server terminated with error (1). Closing log file.
--
Chris Elvidge
England
Chris Elvidge
2021-07-12 16:48:17 UTC
Permalink
Post by Chris Elvidge
My Slackware system is a Virtual machine on Virtual Box 6.1.22 r144080
(Qt5.6.2) on Windows 10. I don't have Guest Additions installed (they
haven't been needed in the past.)
Slackware 15 (i.e. mirror is slackware64-current)
I'm using the stock 5.12.16 huge kernel at present.
After upgrading (slackpkg upgrade-all) X will not complete startup
/etc/X11/xinit/startx -> startx.xfce.
Anyone have any hints where to go from here?
Any more information required?
To save anyone reading this, I've fixed it.

1) Switched from VboxSVGA to VMSVGA display
2) Installed Guest Additions

It all sprang into life.

Cheers
--
Chris Elvidge
England
Loading...